forum.netbsd.se - NetBSD Sweden

You are not logged in.

  • Index
  •  » Hjälp
  •  » "pipe-knappen" fungerar inte i X.

#1 2005-12-12 21:48:18

priest
Member
Registered: 2005-12-12
Posts: 4

"pipe-knappen" fungerar inte i X.

Tja, jag är helt ny på NetBSD. Har precis installerat och mitt tangetbord fungerar inte som det ska i X. (i konsollen fungerar det)

Problemet är att knappen med "pipe" och höger-/vänsterpil inte fungerar (knappen till vänster om Z).


Tangetbordsdelen från XF86Config:
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "XkbRules" "xfree86"
        Option      "XkbModel" "pc104"
        Option      "XkbLayout" "se"
EndSection
-----------

Jag har testat pc102 och pc101 också, samma fel. Datorn är en laptop med ett externt USB-tangetbord inkopplat. Knappen "fungerar" inte direkt på laptopen heller.

Nån som kan ge lite tips?

Offline

 

#2 2005-12-13 11:50:57

herrgard
Member
Registered: 2005-12-13
Posts: 4

Re: "pipe-knappen" fungerar inte i X.

Testa köra med pc105 smile

Offline

 

#3 2005-12-13 11:59:57

priest
Member
Registered: 2005-12-12
Posts: 4

Re: "pipe-knappen" fungerar inte i X.

Jag har testat med pc105, även med pc100 men det fungerade inte heller. Missade att skriva det i första inlägget bara.

Offline

 

#4 2005-12-13 21:38:49

ceh
Member
Registered: 2004-05-10
Posts: 71

Re: "pipe-knappen" fungerar inte i X.

Du kan ta hjälp av xset(1) och xmodmap(1) för att mappa om tangenter för hand.

xkeycaps i pkgsrc kan även vara intressant, vilket är en grafisk front-end till xmodmap(1).

Offline

 

#5 2005-12-13 22:15:54

mikael
Member
From: Stockholm, Sweden
Registered: 2004-05-11
Posts: 101

Re: "pipe-knappen" fungerar inte i X.

Visst skall man kunna få ett fungerande tangentbord utan att behöva mappa om tangenter för hand.

Offline

 

#6 2005-12-13 22:38:15

mrEriksson
Member
From: Uddevalla, Sweden
Registered: 2005-08-24
Posts: 10
Website

Re: "pipe-knappen" fungerar inte i X.

Har du testat att köra utan XkbRules och XkbModel ? Jag kör själv utan dom och det fungerar fint på alla mina maskiner (bårbara och stationära).

Min konfig ser ut på följande sätt:
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbLayout" "se"
EndSection

Observera att det är en annan drivare också. Vet inte om detta påverkar något, eller om det kommer från just det faktum att jag kör xorg, men kan ju vara värt att titta på i ett senare skede.

Lycka till!

Offline

 

#7 2005-12-14 16:34:12

priest
Member
Registered: 2005-12-12
Posts: 4

Re: "pipe-knappen" fungerar inte i X.

Hmm..  Jag har hittat en "lösning", men jag förstår verkligen inte varför det blir så här.

När jag väl har startat X (kör fluxbox) och kör "setxkbmap fi" så får jag ett helt fungerande tangetbord. Om jag ändrar defaultlayouten till "fi" i XF86Config så blir det exakt samma fel som det var från början. Men om jag byter till "fi" när jag väl startat upp X med "se" så fungerar det som sagt.

Någon som har en förklaring?

Offline

 
  • Index
  •  » Hjälp
  •  » "pipe-knappen" fungerar inte i X.

Board footer

Powered by PunBB
© Copyright 2002–2008 PunBB