forum.netbsd.se - NetBSD Sweden

You are not logged in.

#1 2007-10-24 09:11:57

z999
Member
Registered: 2006-02-20
Posts: 116

nfs och diskless

Hej

Jag håller på med en diskless install. Bootningen fungerar och dhcp ger den nödvändiga informationen, men sen när clienten ska hämta netbsd/boot så kommer "Boot failed, permission denied". Jag har testat med chmod 777 på netbsd men det hjälpte inte. Jag har inte ändrat kerneln på servern men håller ändå på just nu att kompilera en ny (GENERIC) för att få med nfsgrejjerna i den. Men dessa är väl med i grundkonfigurationen?

Filerna som ska hämtas ligger i en egen partition /export. Jag har innan haft /usr/local/export och ingen egen partition (detta fick mountas under /mnt/export med mount null för att få det att fungera).

/etc/exports ser ut så här-
/usr -ro client
/export -maproot=root:wheel -alldirs client

/etc/hosts är konfigurerad så att client kopplas till ett ipnummer. När jag testade
192.168.1.100:/etc/export -maproot=root:wheel -alldirs client i /etc/exports så kom ett meddelande som sa något i stil med "No automount configured" (tror jag det var). Brandväggen är konfigurerad för att låta den interna trafiken flyta.

Offline

 

#2 2007-10-25 13:55:36

z999
Member
Registered: 2006-02-20
Posts: 116

Re: nfs och diskless

"/etc/hosts är konfigurerad så att client kopplas till ett ipnummer. När jag testade
192.168.1.100:/etc/export -maproot=root:wheel -alldirs client i /etc/exports så kom ett meddelande som sa något i stil med "No automount configured" (tror jag det var)."

Undrar varför när man blandar ihop fstab med exports :-) Hoppa över det.

En annan sak. När jag har freebsd installerat i en soekris net4801 så fungerar det inte speciellt bra när jag ska logga in med nollmodemkabel med tip från en annan freebsd-maskin. Med NetBSD fungerar det perfekt. Jag har kollat /etc/ttys och paritet vid överföringen och har ändrat skärmen till vt100 och vt220. I netbsd fungerar det perfekt att logga in och sedan använda vi för att konfigurera filer, i freebsd vill det sig inte alls trots att det är freebsd i lådan. Om jag ssh'ar in i lådan med FreeBSD så fungerar det hjälpligt. Är det något i kerneln som är default i netbsd men inte i freebsd?

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2008 PunBB