- NetBSD Sweden

You are not logged in.

#1 2008-05-03 02:16:07

Registered: 2008-05-03
Posts: 2

current kernel track

I am a long time linux user and i figure out i should give netbsd a
try. I downloaded NetBSD 4.0 installed it on my system. I read
but it's not so well structured for my taste I just can't figure out a
few things.

I want to test the latest kernel (current) so i get it through anoncvs
(equivalent as taking the linux source with git i'm not lost here
tongue). Now do I have to get anything else on a fresh installed NetBSD4.0
to compile and use the current kernel just for testing?
There are a lot of informations on that site i just can't figure out
which one to follow.

I don't want my whole system current just want to get the current
kernel compile it and put it along with the one i have so i can chose
to run it.

So please help a confused young netbsd user.



#2 2008-05-03 10:54:29

From: Göteborg, Sweden
Registered: 2004-05-10
Posts: 229

Re: current kernel track


if you have obtained the -current source the only thing you have to do to build your kernel is

cd /usr/src
/ tools kernel=GENERIC
Where GENERIC is a standard kernel, but it can be replaced by your own custom kernel config located in /usr/src/sys/arch/<arch>/conf/

To have an 4.0 userland and a current kernel sounds like a really bad idea, your system will most likely be out of sync and you will probably end up with a lot of non working stuff and strange errors.



#3 2008-05-04 19:04:44

Registered: 2008-05-03
Posts: 2

Re: current kernel track

Well correct me if i'm wrong because i tried it 6 times and it always
fails and it takes a hell lot of time.

One clean install of NetBSD 4.0
#cd /usr
#mkdir src objdir tooldir
#chown someuser src/ objdir/ tooldir/

as someuser:

$export CVS_RSH=ssh
$cvs checkout -PA src

also today to make sure i'm up to date:
$cd /usr/src
$cvs -q -d $CVSROOT update -dP
#chown -R someuser:wsrc /usr/src
#chmod -R u=rwx,g=rwx /usr/src

$cd /usr/src
$./ -O ../objdir -T ../tooldir -U -u tools
$./ -O ../objdir -T ../tooldir -U -u distribution    (also
tried release)

well this is where it fails miserably with release or distribution
So please HELP because this trial && error process is taking a
painfull amount of time.




#4 2008-05-05 12:37:03

From: Sweden, Umeå
Registered: 2004-05-10
Posts: 73

Re: current kernel track

When I tracking current I do like this:

# cd /usr
# mkdir src xsrc objdir tooldir releasedir destdir
# chown someuser src/ xsrc/ objdir/ tooldir/ releasedir/ destdir/
# logout

$ export
$ export CVS_RSH=ssh

$ cvs checkout -PA src
$ cvs checkout -PA xsrc

$ cd /usr/src
$ ./ -T ../tooldir -D ../destdir -R ../releasedir -O ../objdir -U tools
$ ./ -T ../tooldir -D ../destdir -R ../releasedir -O ../objdir -X ../xsrc -U -x -r release

tada :-)




#5 2008-05-05 19:33:15

Registered: 2004-05-10
Posts: 71

Re: current kernel track

First, -current is work in progress and may be broken from time to time; it won't always build. You might have catched the source in such a moment.

Second, why is the build failing? We can't tell by the information you provided. Please provide more details, such as error messages and platform (amd64, macppc, ... ?).

You might for an example produce a file with the output (error messages) by appending "2>&1 | tee ../buildlog" to your line.

Example: ./ -O ../objdir -T ../tooldir -U -u distribution 2>&1 | tee ../buildlog



Board footer

Powered by PunBB
© Copyright 2002–2008 PunBB